Page tree
Skip to end of metadata
Go to start of metadata

Product Version: 7.0
Last Modified: 31 May 2017

Problem

Warning message is displayed when adding 4.1, 5.0, 5.1 ESXi hosts to NAKIVO Backup & Replication’s Inventory.

An SSL error has occurred on the transporter while trying to connect to the host. ESXi 4.1, 5.0 and 5.1 require deploying a special transporter. 
Otherwise, the jobs using this host in LAN mode will fail.

Background

NAKIVO Backup & Replication Transporter establishes a secure connection with an ESXi host. The connection is handled by the OpenSSL library which is a part of VADP (vSphere APIs for Data Protection) package used by NAKIVO Backup & Replication. The OpenSSL version used in ESXi 4.1, 5.0, and 5.1 is not compatible with the new OpenSSL library used in the most recent VADP package. Connection to the older version of ESXi hosts fails with an SSL error.

Solution

Use one of the approaches described below:

Linux

  1. Download a special Transporter that supports old ESXi versions: 
  2. Follow the usual update procedure.

Windows

  1. Download a special Transporter that supports old ESXi versions: 
  2. Stop the Transporter service
  3. Extract the files from the archive you downloaded in step 1 to the Transporter folder. By default this is C:\Program Files\NAKIVO Backup & Replication\transporter 
  4. Start the Transporter service.
  • No labels